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Thème numèro 8  
Principaux points abordés dans ce thème : 

1 Création d’une liste 

2 Saisie de données dans une liste 

3 Tri d’une liste 

4 Filtrage d’une liste 

5 Insertion de sous-totaux dans une liste 

8.1. Création d’une liste 

Après avoir ouvert EXCEL, dans le nouveau classeur, introduisez les 

libellés suivants : 

 
 B C D E 

1 Région Département Représentant Ventes 

Ces libellés constitueront les en-têtes de colonnes de la liste 

• Sélectionnez le bloc B1:E1 

• Centrez horizontalement les données dans les cellules, grâce à la 

rubrique de menu Accueil→Alignement→[→] (Home→ 

Alignment→[→] en anglais), onglet Alignement, liste déroulante 

du cadre Horizontal , choisir Centré ( Center ). 

• Validez par OK ou [Entrée] ( [Enter] ) 

Conservez sélectionné le bloc B1:E1 

8.2. Saisie de données dans la liste 

• Avant de pouvoir utiliser cette rubrique, il faut la faire apparaitre 

dans la barre d’outils accès rapide. 

• Cliquer sur la flèche à droite de la barre d’accès rapide (située au-

dessus du ruban, à gauche), un menu apparait 
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• Choisir la rubrique Autres commandes… Une fenêtre apparait 

alors. 

• Dans la liste catégorie de commandes (en haut à droite), choisissez 

« commandes non présentes sur le ruban » ou « Toutes les 

commandes», puis « Formulaire ». 

• Cliquer sur « Ajouter>> » 

• Valider par OK 

• L’icône apparait maintenant dans la barre d’outils accès rapide 

(au-dessus du ruban) 

 

     

• Activez cette nouvelle rubrique « Formulaire » («Form »). 

Il apparaît la boite de dialogue suivante : 

 

 

Validez par [Entrée] ( [Enter] ), ou Cliquez sur le bouton Ok.  
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Vous voyez s’afficher la grille de saisie suivante : 

 

 

Vous allez introduire grâce à cette grille les données suivantes (ou toute 

autre série de données du même genre, à votre gré) : 
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Pour ce faire : 

• cliquez sur le bouton Nouvelle. Le curseur d’insertion se place dans 

la zone Région de la grille. 

• Introduisez le nom de la région de la première fiche 

• Frappez la touche [Tabulation] qui porte le symbole ci-dessous : 
 

 

 Le curseur d’insertion se place dans la zone Département de la grille. 

• Introduisez le numéro de département. 

• Frappez la touche [Tabulation] 

• Introduisez le nom du représentant de la première fiche 
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• Frappez la touche [Tabulation] 

• Introduisez le montant des ventes de la première fiche 

• Frappez [Entrée]. La première fiche s’enregistre, vous pouvez 

recommencer les opérations précédentes pour la seconde fiche et 

ainsi de suite jusqu’à la dernière 

Pour rectifier une erreur, vous pouvez aller de fiche en fiche grâce 

aux touches de déplacement vertical  et , ou aux boutons 

Suivante et Précédente ; vous pouvez aussi vous déplacer de 

champ en champ grâce à la touche [Tabulation] qui fait 

descendre, et à la combinaison [Majuscule][Tabulation] qui fait 

remonter, ou bien en cliquant dans un champ. Pour supprimer 

entièrement une fiche, cliquez sur le bouton Supprimer, qui est 

actif lorsqu’on se trouve positionné sur une fiche. Les fiches qui 

suivent remontent alors d’un cran vers le haut. 

Remarque : Après vous être familiarisés avec la grille de saisie, vous 

pourrez constater qu’il est plus aisé de remplir la liste directement. 

Microsoft a voulu trop bien faire… Fermez donc la grille grâce à son 

bouton Fermer et renseignez directement le reste du tableau. 

8.3. Tri de la liste 

Nous allons trier cette liste dans son ordre naturel, avec: 

o le nom de région comme clé majeure 

o le numéro de département comme clé intermédiaire 

o le nom de représentant comme clé mineure. 

Nous aurons ainsi : 

o l’une derrière l’autre les ventes d’un représentant ; 

o les uns derrière les autres, les représentants d’un même 

département ; 

o les uns derrière les autres, les départements d’une même région 

; 

o les unes derrière les autres, les diverses régions. 

• Sélectionnez les colonnes B à E : 
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• Sélectionnez la colonne B, en cliquant près de la lettre B 

• Maintenez enfoncée la touche [Majuscule] 

• Sélectionnez la colonne E, en cliquant près de la lettre E 

• Activez la rubrique de menu Données→Trier & Filtrer→Trier 

( Data→Sort & Filter→Sort). 

• La boite de dialogue qui s’affiche contient une ligne, pour spécifier 

la première clé de tri: 

 

• Choisissez « région » 

 

• Cliquer sur le bouton « Ajouter un niveau » pour spécifier une 

seconde clé de tri,  

• Choisissez, de même, Département comme seconde clé, avec un 

ordre Croissant, et  

• Recommencez pour spécifier Représentant comme troisième clé, 

toujours en ordre Croissant. 

Cocher Mes données ont des entêtes pour exclure du tri les entêtes de 

colonne. 

 

Enfin validez en frappant [Entrée] ou en cliquant sur le bouton Ok. 

Excel trie immédiatement les lignes dans la liste. Voici le début de la 

liste triée : 
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8.4. Filtrage des données d’une liste 

A titre d’exercice, nous allons extraire de notre liste les noms de tous 

les représentants d’Ile de France, sans répétition. 

Pour ce faire, nous devons créer un bloc de résultats et un bloc de 

critères. Nous créerons le bloc de critères en F1:F2 ; nous créerons le 

bloc de résultat en colonne G. 

• Recopiez (en utilisant le copier/coller) en F1 le texte Région qui se 

trouve en B1. L’opération de recopie assure que les contenus des 

cellules B1 et F1 seront rigoureusement identiques. 

• Recopiez en F2 le texte Ile de France que vous prendrez dans une 

des cellules de la colonne B. 
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On prépare ainsi un bloc de critères qui demande la sélection des lignes 

de la liste qui contiennent Ile de France dans la colonne dont l’en-tête 

est Région. 

La colonne F est a priori trop étroite pour contenir le texte « Ile de 

France ». Elargissez-la par une des deux méthodes suivantes : 

• première méthode 

o sélectionnez la colonne, en cliquant près du “ F ” 

o activez la rubrique 

Accueil→Cellules→Format→Ajuster la largeur Colonne 

(Home→Cells→Format→Autofit Column Width en 

anglais) 

• seconde méthode 

o Amenez le pointeur de souris sur le trait qui sépare les en-

têtes des colonnes F et G. Il prend la forme de deux flèches 

horizontales, dos à dos, encadrant un trait vertical :  

o double-cliquez en ce point 

• Recopiez en G1 le texte Représentant qui se trouve en D1. 

On prépare ainsi en colonne G un bloc de résultat qui demande 

l’extraction, du champ Représentant de chacune des lignes choisies. 

• Très important : n’oubliez pas de sélectionner ensuite à nouveau 

les colonnes B à E 

• Activez la rubrique Données→Trier & Filtrer→Avancé 

(Data→Sort & Filter→Advanced). Sur l’écran s’affiche la boîte de 

dialogue qui suit : 

 

La plage de données a été déterminée par 

EXCEL, grâce au fait que les colonnes B 

à E étaient sélectionnées. EXCEL s’est 

arrêté à la dernière ligne garnie de la 

liste. Vous pouvez remarquer que cette 

référence de bloc s’affiche sous la forme 

absolue. 

Le bouton qui permet de sélectionner la base de données ici 

$B$1:$E:$E30 

la zone de critères, ici $F$1:$F$2; et 

la zone de destination, ici $G$1 
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Cliquez sur le bouton à droite de la boite de saisie de la 

Zone de critères ( Criteria Range ), puis sélectionnez le bloc F1:F2. 

Le texte !$F$1:$F$2 s’affiche dans une petite barre d’outils qui est 

apparue lorsque vous avez cliqué sur le bouton. Le bloc de critères sera 

F1:F2. Ici encore, la référence est absolue, et le point d’exclamation 

sépare la référence de bloc de la référence de feuille. Celle-ci étant la 

feuille courante, la référence de feuille est vide. 

Validez le choix de la zone de critères en frappant [Entrée] ( [Enter] ). 

Vous revenez à la boîte de dialogue du filtrage. 

• Validez le bouton-radio Copier vers un autre emplacement ( Copy 

to another location ). 

• Cliquez sur le bouton à droite de la boite de saisie Destination 

( Copy To ), qui est désormais accessible (l ’étiquette Destination 

n’est plus en grisé), puis cliquez dans la cellule G1 

Le texte Feuil1!$G$1 s’affiche dans une nouvelle petite barre d’outils. 

Ici, curieusement, EXCEL affiche la référence de feuille en entier. Le 

bloc de résultat est à présent la colonne G, sans limitation dans le sens 

vertical, car le bloc de résultat ne contient qu’une ligne. 

Validez le choix de la zone de destination en frappant [Entrée] 

( [Enter] ) 

• Validez par [Entrée] ou en cliquant sur le bouton Ok de la boîte de 

dialogue. Vous obtenez le tableau qui suit : 
Représentant 

Duhamel 

Rousseau 

Plantier 

Marmet 

Bermelin 

Franchet 

Franchet 

Merville 

Charpentier 

Mousson 

Garnier 
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Vous pouvez constater que le nom de Franchet apparaît deux fois dans 

la liste extraite. C’est normal, la suppression des doublons n’était pas 

activée. 

• Activez à nouveau la rubrique 

Données→Trier & Filtrer→Avancé (Data→Sort & Filter 

→Advanced en anglais). Vous retrouvez la même boite de dialogue, 

avec les mêmes contenus de boîtes de saisie. N’oubliez pas de cocher 

à nouveau le bouton-radio Copier vers un autre emplacement, qui 

n’est plus sélectionné, et cochez à présent la case 

Extraction sans doublons ( Unique Records only ), puis validez 

par [Entrée] ou en cliquant sur le bouton Ok.Vous obtenez à présent 

en colonne G la liste sans doublons : 
Représentant 

Duhamel 

Rousseau 

Plantier 

Marmet 

Bermelin 

Franchet 

Merville 

Charpentier 

Mousson 

Garnier 

 

8.5. Insertion de sous-totaux dans une 
liste 

Pour insérer des sous-totaux dans une liste, il convient que la liste 

soit triée. Dans notre cas, étant donné l’ordre de tri de notre liste, 

nous pourrons insérer des sous-totaux de la colonne Vente à 

chaque changement de région, à chaque changement de 

département et à chaque changement de représentant. 

• Les sous-totaux au niveau du représentant regrouperont les 

ventes de ce représentant 

• Les sous-totaux au niveau du département regrouperont les sous-

totaux des représentants du département 
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• Les sous-totaux au niveau de la région regrouperont les sous-

totaux des départements de la région 

Les sous-totaux doivent être créés en allant du niveau le plus global 

vers le niveau le plus détaillé. Nous commencerons donc par le niveau 

Région. 

• Effacer le contenu des colonnes F et G (qui faisaient l’objet de 

l’exercice d’extraction précédent) 

• Sélectionnez à nouveau les colonnes B à E. 

• Activez la rubrique de menu Données→Plan→Sous-total 

( Data→Outline→Subtotals ). EXCEL affiche la boîte de dialogue 

qui suit : 

 

• Sélectionnez Région dans la boite de choix 

A chaque changement de ( At each change in ). 

• Conservez le choix de Ventes dans la boite de choix 

Ajouter un sous-total à ( Add subtotal to ). 

• Conservez le choix Somme dans la boite de choix 

Utiliser la fonction ( Use function ). 

• Laissez cochée la case Synthèse sous les données  

( Summary below data ). 

• Laissez cochée, pour cette fois seulement, la case 

remplacer les sous-totaux existants ( Replace current subtotals ). 



Excel  Séance 4 – 2eme Partie 

 

Madame Véronique HEIWY 

L’usage de cette brochure est réservé exclusivement aux travaux dirigés de l’Université PARIS 1, UFR 

Gestion-Sorbonne, L2 

• Validez par [Entrée] ([Enter]) ou en cliquant sur le bouton Ok. 

o Elargissez la colonne B grâce à la rubrique 

Accueil→Cellules→Format→Ajuster la largeur de 

colonne (Home→Cells→Format→Autofit Column Width 

en anglais), ou en double-cliquant sur le trait qui sépare les 

en-têtes de colonnes. 

• Recommencez les mêmes opérations, depuis l’activation de la 

rubrique Données→Plan→Sous-total 

( Data→Outline→Subtotals ) jusqu’à la validation par [Entrée], en 

sélectionnant successivement Département et Représentant dans la 

boite de choix A chaque changement de, mais cette fois invalidez 

la case remplacer les sous-totaux existants, sinon vous détruiriez à 

chaque fois les sous-totaux installés à l’étape précédente. Vous voyez 

progressivement s’afficher les différents sous-totaux que vous avez 

demandés, entre les lignes de votre liste. Déselectionnez enfin les 

colonnes B à D : 

 

Vous pouvez remarquer vers la gauche de l’écran une zone couverte de 

boutons, avec sept boutons en haut. Cette zone matérialise le plan qui 
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structure à présent votre feuille de calcul. En cliquant sur un des 

boutons du haut, vous pouvez fermer un ou plusieurs niveaux de détail. 

Par exemple, si vous cliquez sur le bouton marqué 2, vous obtenez 

l’affichage suivant : 

 

Chaque bouton marqué  +  permet de « déplier » individuellement une 

région, alors que les boutons marqués  -  permettaient de « replier » 

individuellement une région (à ce niveau 2). 

Remarque : La création d’un plan n’est pas limitée à l’insertion de 

sous-totaux automatiques dans une liste. 

• EXCEL est capable de créer automatiquement des plans, dès l’instant 

où existent dans le tableau des lignes de détail séparées par des 

lignes récapitulatives, où les lignes récapitulatives contiennent des 

formules qui font référence à des lignes de détail situées au-dessus 

d’elles. 

• Il est également possible de créer un plan à la main, nous allons en 

donner un exemple : 

Dans une feuille vierge, que vous obtiendrez en activant la rubrique 

Insérer du menu contextuel de l’onglet de la feuille courante (clic droit 

sur l’onglet),  

• sélectionnez le bloc A1:A4. 

• Activez la rubrique de menu Données→Plan→Grouper 

( Data→Outline→Group en Anglais ) 

• EXCEL affiche une petite boite de dialogue, qui vous demande de 

choisir entre grouper par Lignes ou par Colonnes :  
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Puisque EXCEL n’est pas totalement stupide, il a pu constater que 

votre bloc comportait plus de lignes que de colonnes et vous propose 

donc de grouper par Lignes.  

Validez en frappant [Entrée] ou en cliquant sur le bouton Ok. 

Vous voyez s’afficher sur la gauche de 

l’écran les boutons caractéristiques du 

mode plan : 

Si vous cliquez sur le bouton  -  ou sur le 

bouton  1 , le groupe se « referme » : 

• les lignes 1 à 4 disparaissent 

• le bouton  -  se transforme en  +  et 

remonte, donnant ainsi l’affichage ci-contre : 

• En cliquant sur le bouton  + , vous ouvrez à nouveau le groupe, et 

vous faites réapparaître le bouton  - . 

• Vous pouvez à présent créer un second groupe, par exemple 

constitué des lignes 6 à 20. Sélectionnez le bloc A6:A20,  puis 

activez la rubrique Données→Plan→Grouper 

( Data→Outline→ Group en Anglais ). Validez ensuite par 

[Entrée] ([Enter]) ou en cliquant sur Ok. Il faut laisser une ligne 

entre les deux groupes, sinon EXCEL les fusionne. Si vous 

refermez le second groupe, le tableau semblera commencer par la 

ligne 5, qui sera immédiatement suivie de la ligne 21. Si vous 

cliquez sur les deux boutons +, toutes les lignes réapparaissent.  

• Pour créer un plan à plus de deux niveaux, il faut prendre la 

précaution de réserver une ligne récapitulative pour chaque 

niveau, sinon EXCEL ne comprend rien. Exemple : 

• Prenez une autre feuille vierge. 
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• Groupez les cellules du bloc A1:A2. La ligne récapitulative est la 

ligne 3. 

• Groupez les cellules du bloc A4:A5. La ligne récapitulative est la 

ligne 6. 

• Laissez libre la ligne 7 pour servir de ligne récapitulative au 

groupement de ces deux groupes. 

• Groupez les cellules du bloc A8:A9. La ligne récapitulative est la 

ligne 10. 

• Groupez les cellules du bloc A11:A12. La ligne récapitulative est 

la ligne 13. 

• Vous pouvez ensuite grouper les cellules du bloc A1:A6, puis 

celles du bloc A8:A13. Vous voyez apparaître un troisième 

niveau de plan (le niveau 1 est le niveau le plus global, lignes 1-6 

et 8-13 ; le niveau 2 est le niveau intermédiaire,lignes 1-2, 4-5, 8-

9 et 11-12 ; le niveau 3 est le niveau de détail). 

• Vous pouvez enfin grouper les cellules du bloc A1:A14. Un 

quatrième niveau de plan apparaît, avec la ligne récapitulative en 

15. C’est ce quatrième niveau qui prend à présent le numéro 1, 

tous les autres numéros de niveau étant décalés d’une unité. 

 


